Won't boot. Need some advice

I just bought Perfect Circuit’s demo SSP unit at a discount and, after connecting the power, I see the initial splash screen flashing over and over. I thought it was a corrupt memory card so I got a new one, flashed it, and got the same result. It almost seems like it’s not getting enough power but my case only has a few other modules. Any thoughts?

oh dear …sorry to hear that, its really disappointing when these things happen :frowning:

after the splash screen, do you see any text scrolling past…
or is it just splash screen, blank, splash screen?

unfortunately, if you have tried a freshly flashed sdcard, Id say its likely a hardware issue.
(as the full OS is on the sdcard , so there is nothing else to change)

hopefully its power related… (rather than a failed ssp)
does your psu give you the required power

assuming it does… what I would try (if you haven’t already) is:

  • disconnect all other modules from the rack
  • ensure nothing is plugged into the SSPs USB slots (these might draw power)

see, if this works… then try adding one module at a time back, see if its a particular combo not working.

(what can happen with eurorack (unfortunately) is some modules can pull a lot of extra power at startup)


if it’s not working even as the only module, and you have the required power specs.
then perhaps something has got dislodged (SoC) when it was shipped to you.
so Id have a quick look at the module - see if anything is obviously not plugged in.

either way, sounds like shooting @bert a DM here, or perhaps contacting him via the contact page on the website is the way to go https://www.percussa.com/contact/
perhaps he knows of something that occasionally comes loose during shipping!?

otherwise I guess it has to go back to Perfect Circuit :frowning:

No text at all. Just the logo appearing and disappearing every several seconds. :frowning:

I’ll try unplugging everything else. And thanks for the reply. I bought the unit largely bc your PMIX solves a particular problem with my setup so thank you for creating it as well!

My power supply is an Intellijel TPS30W MAX

I just tried unplugging everything else and the result is the same. Just the logo coming on and off every couple seconds.

  1. what SD card are you using?
  2. how did you flash the SD card exactly and did you properly eject the card after writing before you removed the card from your computer?
  3. what power brick are you using with your TPS30W MAX bus board?
  4. did you disconnect all other modules in your case such that you only have the SSP connected?
  5. are you using the power cable that came with the SSP? it is not a normal eurorack flat cable but a special power cable.
  6. did you disconnect any USB cables from the SSP just to make sure?
  7. do you have any other bus boards or power supplies to test with?
  1. SD card is SanDisk Extreme 32GB found here: https://www.amazon.com/gp/product/B00G5R75AU/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1

  2. I followed the directions that had me download ssp-sandisk-extremepro-32gb-230720191843 and wrote it to the card using balenaEtcher. Yes, I used the Windows feature to safely eject the media before I removed it. (please note that the issue was also happening on the card that came from Perfect Circuit.)

  3. For the power brick, Elite Modular supplied me with the MW Mean Well Original GSM60A15-P1J 15V 4A 60W AC-DC Reliable Green Medical Adaptor found here: https://www.amazon.com/dp/B07JNN3D63/ref=cm_sw_r_cp_apa_i_fBgOFb4RYNS6T

  4. Yes, only the SSP is connected.

  5. Yes, I am and have only used the supplied black/red cable.

  6. I did not disconnect anything from the SSP. I don’t see a USB cable, unless you mean the side of the power cable that connects to the SSP. For reference, the red strand of the cable is on the inner most pins. Could this be backwards? Should I try flipping it? It came this way.

  7. I’ve tried it on another identical TPS30W MAX with another identical power brick and the result is the same.

Thanks!

what I mean is, did you plug in any USB devices into the front of the SSP? there are 3 USB ports at the front.

on the back of the SSP, near the power connector, it should say -12V, written in black ink. This indicates the correct orientation.

do you have a different bus board to try with and if possible a different power brick? just making sure here.

Yes, i see the handwritten -12v and, yes, the orientation is correct.

No, I’ve plugged nothing into the USB ports.

Unfortunately, I do not have any additional bus boards or power bricks to try.

Any other ideas?

To rule out the possibility that the bus board is the problem you should test with a different bus board. It could be that the bus board has an issue with the large current the SSP draws on the +12V. The SSP gradually increases the current drawn as it boots up so it does not draw all current immediately.

What is the least expensive, known good bus board for me to try?

Might as well give me a known good power brick to look at buying as well. Thx!

I generally recommend a LIBB bus board with a meanwell RT-50B but this involves wiring up mains voltages (dangerous!) and some DIY so not a quick solution to test this.

I have an intellijel 84hp performance case here i use for demos sometimes, i think that has a TPS80W bus board / brick combo. maybe that bus board is an option? you can also check with perfect circuit and see what they suggest.

Great news! I purchased a used Intellijel TPS-80W, which is the same form factor as the TPS-30W MAX. I also purchased a Mean Well GSM90A-15-P1M power brick. Together, these allowed the Percussa to boot properly. I hope this helps someone else in the future. Thanks for your help!

2 Likes