Who has used the SSP as audio interface on Windows 11? Please join thread

So it works on Mac and last update should make it work on windows 10 (from what I understand), but is it supposed to work on windows 11? I received my brand new Ssp a few days ago, figured I’d try to send audio from it into my laptop but it does not recognize it. :frowning:

I am using Ableton live 10.

1 Like

Its presented as a (usb) class compliant audio interface … so it should work on windows 11.

I’ve not personally tried on windows 11, as my only windows machine runs windows 10.
so, not sure, if Microsoft has broken something since then, or if Bert has tested on windows 11.

I guess my best suggestion is checkout my troubleshooting posts Ive written before, to see if you can get some more info to sent to Bert, to isolate the issue.
(Ive also recommend ‘starting order’ as Ive seen some issues about this in the past)
see this post

sorry, not anything I can really add, as I don’t have a machine to test on.


as for windows support, so its been working on windows for quite a while.
it only ‘stopped’ working during the beta version released… once it was out of beta, it was working again.

1 Like

Thanks,

So in the device manager I see it appear as USB audio 2.0 with a little error icon (exclamation point in an orange triangle). When I clicked update driver it said I already have the latest version.

I then clicked uninstall device, restarted my pc and it was still there with the same icon… Tried again but without even restarting I can just scan fornhardware changes in the device manager and it will reappear like I didn’t uninstall it…

Not sure what to do next…
Btw it gives me a code 10

When trying different ports, 2 of them show it under Unknown USB device (in universal serial bus controllers) with error code 43. It also says device descriptor request failed

Btw the firmware I have on ssp (assuming it is the firmware date) is 13072022. So it should be the latest right?

sorry, I don’t know… as I said, I don’t have windows 11… (and my laptop is not compatible)

therefore I cannot say if this is a windows 11 specific issue, or something related to your hardware.
or really what you can try to resolve.

in the past, for me, removing drivers was enough…
the SSP is just using the windows usb class compliant audio driver, so the only real issue would be if for some reason it was picking up something else (or an outdated version of that driver)

I did have this issue with my win10 laptop initially, and this resolved it for me, after than no issues.

yes, 13072022, is latest build.
which is found here
(the beta that doesn’t support windows was something like 29052022)

I should point out, Im just another user, trying to helping out where I can.
you could also try to reach out to Percussa via their contact form

( I will also say, I dont really use windows that much, really only for a bit of testing/development… for music, and so SSP , I tend to use a Mac )

2 Likes

I just sent them an email. Thank you for trying Mark :slight_smile:

1 Like

Just in case this could help/spark an idea, I realized that my pc recognizes the ssp for about 10 seconds before having that error. Here are pictures

Edit:
Opened bluetooth and devices in settings, and found Percussa audio in “other devices” with a driver error message. Tried troubleshooting and it says it can’t find the problem. When going into detail I found that… If that can help too. Problem imho is caused by the SSP, I can use a ps5 controller or any other devices without a problem.

2 Likes

I don’t know if the issue is a hardware problem of the SSP or if microsoft has broken the USB audio class drivers on windows. The SSP works fine on Mac OSX and windows 10 and is USB audio class compliant.

I’ve googled around and it seems other companies making audio interfaces have also had issues with windows 11 but I don’t know what the current situation is.

So let’s try to troubleshoot this some more - is there anyone else here on the forum who has used the SSP on windows 11???

2 Likes

Hi,
I also have a windows 11 machine and tried to get the SSP running.

The errors look pretty similar to @Jturbide 's.

  • unrecognized usb device (yellow exclamation mark) in device manager
  • “Driver error” in the “Devices” view in control panel
  • doesn’t show up in Bitwig / Ardour

This is from memory, let me know if you need more precise details / screenshots.

It works flawlessly on my IPad Air (M1).

(Fwiw, I also tried Linux on the same laptop, didn’t get it to work in Ardour, but I didn’t dig deep…)

Would be super cool if we could get it to run on Win 11.

2 Likes

I’ve had the SSP working fine with (various) Linux, using it with Supercollider, and also Bitwig (which was pretty cool) - but setting up audio interfaces on Linux can be ‘challenging’ at times.

back, to Windows… I think more details the better…
@yp1 did you have the SSP working under Windows 10, with same hardware?
so, the upgrade to 11 broke it?

btw: I assume you are using Windows 11 22H2 , reading thru various audio websites, this is what most are validating against.

re Linux: I didn’t try jack and stuff, just plain ALSA. lsusb recognizes the SSP, but takes a few seconds when it’s plugged in, whereas normally it’s instant, whatever that means :person_shrugging: … Another day perhaps.

re Windows:
No, I didn’t try it under Windows 10. I don’t currently have a machine that runs it, so I can’t try I’m afraid.
I did not yet upgrade to Win 11 22H2 (it’s nagging me, but I didn’t feel like upgrading so far).

Here’s how it looks:
(I’m connecting via an Elektron USB-A to USB-B cable, directly to a port on my laptop, tired both of them.)

(forum doesn’t allow me more than one screenshot at a time, hold on …)

grafik

yeah, it looks like microsoft broke the usb audio class driver again… i think this will be fixed in one of the updates of windows 11 but no clue when.

Same here with Win 11 (laptop) - usb composite device with the ! mark.

OK on Win 10 (desktop) can see the SSP in Ableton 10 and 11, also Reaper - 24 ins and 24 outs with ASIO4ALL

1 Like

Hello friends.
Does it work together with Windows 11 now? Does anyone know?

Thanks //p

Hi all, windows 11 user here just wondering is this still a problem?

I took the leap and bought the SSP anyway and I’m happy to confirm it works fine in Windows 11 now :smiley:

3 Likes

what version of windows 11 have you got? I am stuck on 22H2 and can’t get it working

I’m on windows 11 home 22h2. But maybe it’s got more to do with the particular drivers than the os?

Some of the above posts were suggesting driver issues were due to Windows 11 version - since posting managed to install 23H2 manually and no joy there either. Would you mind sharing a screen grab of the driver versions that are working for you?

EDIT:
OK, I have found the solution. None of USB slots on my laptop work with the Percussa (or my Focusrite 18i20) but using a dongle into the USB-C port gets it working. Stupid to have not tried that sooner, but in other threads about similar issues the use of hubs was outlined as a possible cause. Hope this can help somebody else.

2 Likes