SSP not showing as Audio Device (beta firmware,windows)

As it says, really. Am I alone in this (a me problem) or is this happening to others?

can you give us some details about whats happening exactly?
(more details on initial posts, is always better… so we can get to the point quicker :wink: )

I assume you mean, the SSP is not recognised as a USB audio interface?
however, if you mean, you are having difficulties with sdcard being recognised in card reader, check out these topics.

https://forum.percussa.com/t/exciting-news-software-update-and-superbooth-presence/1511/61

https://forum.percussa.com/t/can-t-open-card-to-transfer-samples/1543


assuming you mean SSP as a usb audio interface under Windows.
indeed my Windows 10 laptop also is not currently recognising the SSP as an audio interface, basically device manager shows an error for ‘USB Audio 2.0’. (*)
note: this work fine on macOS, so its something specific to windows (flakiness :laughing:)

I believe @bert is aware of this issue… hopefully will be fixed for final release.


(*) oddly, I thought on one of the earlier test releases this was kind of working - but I may be mistaken, as I tend not to use Windows for audio work.

It is that windows isn’t recognising it as an audio device, indeed. I’ve previously used the 24 channels, and have Reaper templates set up for it etc… but yeah, simply not being recognised at all anymore.

Glad its a known issue - hopefully there’s resolution soon.

1 Like

k, updated title, so it’s clear if others come across same issue.

appreciate you. sometimes the hard part is as simple as clearly communicating your problem!

1 Like

I’ve updated the firmware image to the latest, tried ASIO4ALL as recommended, tried WASAPI at 192k… and the device simply doesn’t wanna show up on my computer. I hear it connect and disconnect, but nothing.

I’d really love to have this key feature back in action, so any help from anyone with any ideas (idk, does Microsoft blacklist devices it’s had issues with previously?) would be great.

AMD Ryzen 7 3700X 8-Core Processor 3.60 GHz
32.0 GB
Windows 10 Home
Version 21H2
Windows Feature Experience Pack 120.2212.4180.0


EDIT: Looking at device manager when I plug it in, I get these errors:

Information: Microsoft-Windows-Kernel-PnP/Device Configuration
Error: Microsoft-Windows-Kernel-PnP/Device Configuration “had a problem starting.”
Problem: 0xA
Problem Status: 0xC0000001

important note:

this topic was talking about the BETA firmware (and so my previous post), which did NOT have windows support - this was a ‘known issue’, and was fixed in the LATEST release firmware.

so before anything else, you must ensure you are using the latest release firmware, not the beta.
(I’m going to assume you have, but this needs to be 100% clear)

see this post


diagnosis on RELEASE firmware

k, so I just updated my Win10 laptop to latest windows updates to check that Microsoft had not broken anything :wink: and still works ok for me.

Ive tried with both direct and asio4all and seems ok to me - with limited testing I did this time around.
I also used the latest asio4all build - again, just in case.


disclaimer: as Ive mentioned before, I only test occasionally on Windows, as I dont really have a suitable PC for real audio work… and would never want to get one… so my laptop is for dev/test purposes only.

down to business…
so first step is, device loading … there is no point in talking asio4all / wasapi etc, until you know the core audio driver is loading.

next, we have to understand, that the SSP is just seen as a class compliant audio device, and loaded with that driver.
as my setup is very ‘vanilla’, Id say we know that the SSP is ok with the standard Microsoft class compliant driver.

unfortunately, the error you report is just a (typical) generic error for device loading… so doesn’t really give us anything, if you google it, you’ll see others having same error with everything from wifi adapters to usb drives… actually a couple of lines before the ones you show, would have said which driver it had an error with.


generally, this has all been plug n’ play with me with the SSP,
but here are a few tips/tricks that Ive used in the past, to solve issues with other devices and windows

so the first, are all to get the DRIVER loaded, forget asio4all etc, just check in the device manager.

a) level playing field… (ie remove other possible issues/conflicts)

  • have all windows updates installed.
  • remove ALL other devices (except keyboard/mouse ;))
  • restart windows !
    (you can start adding back once you know its working)

b) try a different usb cable, and also different USB ports on your computer.
avoid a hub if possible, and if you have to use one, try different ones.
yeah, I know, this feels dumb, but honestly you’d be surprised how many times this catches people out.

tip: remember we are HOSTING from windows, so you need to plugin into type B port on SSP.

c) connection…
I’ve found often windows/ssp does not like reconnection…

so what I do is

  • power down both PC and SSP
  • power up … unconnected !
  • once powered up, connect usb cable to SSP then PC.

if it does not work, and you try something different… power cycle the SSP, before attempting to reconnect.
(this is important !)

d) uninstall driver.
if the above does not work, then locate the SSP in the device manager, and use ‘uninstall driver’.

( I tend to then power cycle windows)

then power cycle ssp, and plug it in again, see (c), you should get a message about installing the driver… and this will hopefully spark things back into life.

if you google ‘uninstalling device from device manager’ , you’ll get lots more info on this, as its pretty much the go to solution for device issues with windows - lol

basically, when uninstalling you are hoping not only to reinstall the driver code, but also to reset all the settings, that windows might have some how ‘corrupted’ at some point.

really, thats about all I have… usually c/d are the issue with windows,
but as with all diagnostics esp with windows, the trick is to try one step at a time, slowly.
don’t take shortcuts (like not rebooting etc)

Hopefully that will spark things into life for you.

once the driver is loaded, then you can configure things like asio4all or whatever, and test with your daw etc.

only tip there is start with a large buffer (e.g. 1024) and lower sample rate (I use 48k) , and play with it for a bit… checking it ok, before using higher sample rates and smaller buffers.
remember : sample rate/buffer sizes are not just a function of the power of your PC, but also the speed/quality of the USB link, and also to some extent the patch complexity on the SSP.

personally, I keep it at 48k (and iirc) around 512 buffer… that said, I usually plug the SSP into my audio interface… mainly I like the usb class compliant side for midi or plug into things like iOS.

good luck