My Update problems

Sorry but I am having problems and now a huge problem. I am On windows 10 and it was working before I tried to update.
I backed up samples and presets. Downloaded and un zipped sw26082020
Inserted SDcard and Hit do not format on all of the partitions.

Then I used etcher flash from file selected target and flash and properly ejected the SD card from the computer.
Now everything is gone on the card. And I am feeling really stupid I am usually really good at this stuff.

I don’t think I am getting
A OS image because I have to hit the all in view file to see synthor to transfer in etcher. But it shows 5.87 mb under Property’s.

Please tell me I am doing something stupid
Because now the ssp will not boot
And the sd card can not be opened on the PC.

I have asked to buy a updated card but was told that is not possible. And I understand that.
I am frustrated but I am sure it is on me.
I upgraded to windows 10 to make sure it would work.
Is it possible to use a fresh sd card to install to software or did I just brick my system

I have never had problems updating software-firmware befor on other things.
Like I said it is on me there is just something I am not getting

I don’t know if it is possible or allowed but at this point I would pay 100 us to get a updated card
Without your samples or presets. I am in Akron ohio
I am really freaking out at this point.
Talk me off the ledge please.
Thank you in advance.

Hi there, I had exactly the same issue and like you, PC with Win10, it is not what you have done. I put this down to either SDcard, despite these being quality and reliable SDcards, but more than likely Etcher had a hiccup during the process. All you can do is purchase another same card from anywhere Amazon/Supermarket and I am confident it will work as it did for me. Don’t do anything else on windows whilst Etcher is doing its thing. Good luck, let us know how you get on.

Thank you
I have 2 new cards that arrived today.
Just to make sure when I download and unzip the update there is not a os image just a plug-in folder and a synthor file.

Do I need a different file to download first then do the update.

you first have to flash the image on the card, if that succeeds you can apply the update (with the 2 files you mention)
i can be correct that you only see xxMB , according to which partition you look at
so you don’t have to partition, elena etcher software will do the partition for you

Sorry for late response, due to time zones, wavejockey has explained well. I just followed the instruction for the big update that needed Etcher and your done, nothing more.

this is not a disk image.

this can be a bit confusing… so I’ll try to be clear…

the SSP runs a linux operating system, on top of this it runs an ‘application’ (synthor) which is the thing you see on the display

so updates can come in two forms :
i) a complete disk image - which contains the entire operating system (linux, drivers etc) , this is many gigabytes, and needs to be flashed with ETCHER (or similar) directly to the sdcard.
this is fairly ‘rare’ to update, only once since release so far… as its only required when new drivers etc are required.
b) synthor update - these are more common, since this is the ‘application’ being updated e.g. to provide new features or fix bus , and are only a few megabytes


so starting from scratch on a new sdcard, you would need to

i) download and flash disk image
you do not need to worry about format, etcher will completely overwrite partitions and anything on the sdcard
SO this will therefore overwrite your presets/samples, so back them up

the latest disk image can be found here: (at this time!)
https://forum.percussa.com/t/update-23072019-multichannel-usb-audio-cv-gate-trigger-streaming-update-input-and-output-module-simplifications-and-improvements

after you have done this, pop it into the SSP and check that it works…

then…

ii) update to latest ‘synthor’
synthor has been update since the last disk image was created, so you will now want to update to the latest synthor.
this is just copied to the sdcard to replace the existing SYNTHOR
this will NOT affect your presets or samples.

the latest synthor can be found here : (at this time!)

https://forum.percussa.com/t/fix-28112020

1 Like

Thank you
I tried to read everything I could but this is exactly what I needed

Thank you
I has having problems finding the os image to flash
Because my card failed when I tried to update.
I did not realize you just drop and drag for normal updates
But a link was shared and all i am sure will be good now

Thank you for the response
I am on the right path now

Update it is working :+1:t2:
Thank you all for your help
Now that I understand the process it was right in my face all the time.
Sorry I did think I looked at everything but panicking makes your brain shutdown.

I just can’t get the card to open on windows 10 to copy my samples presets and do the latest update.
It will not let me access the sd card. I could before I messed everything up. The boot drive would show if the file menu of the SD card but now unrecognized.
But I can keep working on that it is awesome to have the 24 by 24 interface option now.
And all the new updates to the point of the new firmware flash.
Thank you for your hard work this is a great addition to my work and play flow.

2 Likes

Hi, great to see you up and running, i know how frustrating it can be. Not sur why Win 10 does not recognise multiple drives and boot drive on SDC.

As advised, i also use win10 and in an attempt to use as interface, using Asio4all and bitwig with settings already noted on this forum, cant get it to recognise SSP driver (well cant select SSP in Bitwig, as i would my Motu driver) on test of audio out, levels and audio but first channel out goes to channel 6, or is it 7 :thinking:. Can you let me know what you are using for it to work on Win10.

Cheers

Hi
so far I have just used it with a iPad Pro running Mi rack and BeatMaker 3 Cubasis 3 etc
This thing is awesome and just works. It replaced a expert sleepers es8, morphagene and instruo arbhar. I will try later on my big system width Nuendo 11. My plan for it is to run VCV rack on a Mac m1 and link into my stage boxes on the wing. Plus as a killer little portable system
I use a behringer wing as my main interface

I will let you know how my windows audio experience goes.

2 Likes