LAN Port?

Wondering if Percussa has a LAN port inside. This would make it easy to transfer files over wifi without having to connect any cables to it.

1 Like

There is no ethernet port on the SSP but you can buy a usb-ethernet dongle, and plug it into the USB high speed host port of the SSP (the leftmost port). This one is what I use and will work (the chipset is important):

The SSP’s static IP address is The default username/password to login via SSH is linaro/linaro. You will have to configure your router so there is no IP address clash on your network. Of course you can change the IP address but to do that you have to log in first via SSH or use the SSP’s serial console, go into /etc in the root file system, and then follow the normal linux (debian) howtos for networking to make your changes. I cannot provide linux support, so you’re on your own there. The root file system is a debian stretch distro from linaro.

If you cannot SSH into the SSP then the linux network config doesn’t recognize your dongle’s unique ID correctly and then you have to first use the serial console on the SSP. The SSP has a 10-pin pin debug header on the back to which you can connect a USB-serial cable. If you want to do it this way let me know and I’ll post the pinout here and a link to a cable you can buy.

Hope this helps.


details on the serial debug / console port on the back of the SSP. The signals you need to connect are GND, FTDI_RXI (receive input) and FTDI_TXO (transmission output).

You need to use a USB-serial cable like these ones from FTDI -

I am using a TTL-232R-3V3-WE

I use serial on the Mac or TeraTerm on the PC. You have to configure your serial port for baud rate 115200, other than that the typical defaults (8N1). If you don’t see any data swap the RX and TX.

Do not connect any power pins on this debug header.

for @jason and others who want to write applications for the SSP and want to know how to read the encoders and buttons:

you just use standard linux file I/O to read from the following devices:


More info can be found online regarding reading device files on linux, including examples.

All the Audio I/O on the SSP works via ALSA, which is the standard linux audio API. The ALSA driver has a feature to switch AC/DC coupling on the SSP’s inputs.


Thanks for the info!

I’ve just got the Plugable dongle suggested, and unlike the other one I have, the LEDs come on!

Unfortunately, though, I cannot ping nor SSH to I also did a network scan with and without the SSP connected, and it doesn’t seem to come online with any IP in my 192.168.0.x subnet.

Perhaps I need to take the additional steps you mention, Bert? What might I try next?

I’m hoping to simply use this to transfer samples and recordings to and fro without power cycling or dealing with the SD card.

you need to get a USB-serial cable and wire it up to the SSP’s serial port (see other info in the forum here).

this will let you access the serial console, after which you can navigate to /etc/network/interfaces.d/ and create an interface file for your USB ethernet adapter’s unique ID, in which you put the static IP address you want to use. If all your IP addresses on your network are of the form 192.168.1.x then you can choose for example. You might need to config your router so it does not use any IP addresses under 10 for example, such that 1-10 are available for static IP addresses.

to find the ID you can do sudo dmesg | grep asix on the command line. It typically has the format enx…

so you would copy one of the existing files in /etc/network/interfaces.d/ to have a file name that matches your USB-ethernet dongle’s unique ID, then edit that file so it has the IP address you want, and then you power cycle the SSP and you should be able to SSH into it (see login/passwork info elsewhere in the forum).

if you have any questions let me know. Typing this pretty late here before tomorrow’s superbooth show.

Thanks, Bert. I just ordered this one

Will report back how it goes.

Have fun out there!

that should work, just connect GND, TX and RX and do not connect the +5v wire

if it doesn’t work swap RX and TX

use baud rate 115200, and 8N1 settings
on mac you can use the serial app and on windows terraterm

Cool! I can see the boot process and get my root shell with the serial connection. I created the file, /etc/network/interfaces.d with

auto enx8cae4cebd01b
iface enx8cae4cebd01b inet static

Interestingly, it didn’t seem to work. Then I tried a dhcp configuration I found on the Debian wiki,

auto enx8cae4cebd01b
allow-hotplug enx8cae4cebd01b
iface enx8cae4cebd01b inet dhcp

Not sure why that didn’t work, either (found nothing, scanning my subnet) but

When I went back to the same static config I initially tried and gave it another reset, it came online! Maybe I had goofed something, but I dunno.

Anyway, thanks again!

It’s possible it needed a reset/reboot to detect the dongle, glad it worked out.

The boot partition of the sd card is mounted at /media/linaro/BOOT

Hi, celine! Thanks for that. Yeah, I did find the files in /media/linaro/SYNTHOR … I notice /etc/fstab says its label is BOOT, but I guess it’s not exactly the name of my directory somehow.


yes you are right, that is the correct mount path.

you should be able to use filezilla, sftpdrive or other FTP clients supporting the SSH/SCP protocol.

of course you can ssh into it as well, see login info elsewhere in the forum.

Ive just been setting up my dev environment so stumbled on this, and thought id add some tips :slight_smile:

finding interface name without having to resort to a serial cable!

ok, I didn’t want to start grabbing a serial cable and messing about with pin headers.
the way I found the details was much simpler…

use another linux system (the one you installed for the ssp-sdk will do !) and load the rootfs from the sdcard of the SSP.

you can then edit in your ‘host’ system home/linaro/

simply then comment out the last line so

sudo startx /media/linaro/SYNTHOR/SYNTHOR 


#sudo startx /media/linaro/SYNTHOR/SYNTHOR 

then eject your sdcard, and put back in the SSP.

(I also found it useful to comment out the line, so that the boot log files were not overwritten when ssp boots up, but remember to change it back later :wink: )

what this will do is prevent the main synthor process starting… instead you’ll end up at the command prompt on the SSP , now plug in an usb keyboard, and you can log in with linaro/linaro

when you then plug in your usb ethernet stick, you can use dmesg to check for its name,
and create a file in /etc/network/intefaces.d as described above.

the best way to ‘test’ this is to restart the networking service using

/etc/init.d/networking restart


then you can check the network is available with

ip a

check the interface you configured is UP, and that it has the correct ip address…

check you can access your SSP remotely,

now its working, you can edit /home/linaro/ (on the ssp) and uncomment the line (i.e revert one you did at the beginning) …

some other notes… whilst I was there

a) wifi
Ive got a few wifi stick and none were recognised, by usb subsystem - so either the kernel modules are missing they are very standard rPI sticks, so thats a surprise …

(might just need to do mdprobe to bring it in manually, as I notice this appears to be being done for the audio interface gadget)

b) dhcp
dhcp worked fine for me, but it appears ssp is not broadcasting hostname, so its not particularly used - its easier to use a static ip address

EDIT: usb wifi
I did a bit of digging, unfortunately looks like although the rt2800usb driver is present, it appears to be an older one that doesn’t support the 5370 chipset that i have. I’ve got a another wifi stick, but that chipset is also not support.

i could potentially rebuild the kernel modules, and ensure the 5370 is supported, but the ethernet dongle is fine for now.

@bert perhaps next release that you build you could include support for the ralink 5370 chipset (this might just mean a later kernel build) ?
Wifi does have a musical use too… support for Ableton Link :slight_smile:


Networking n00b question, I guess: can the USB ethernet dongle work directly connected to another computer, or does it have to go through a router?

I have the Apple USB Ethernet dongle connected, which a quick Google search indicated had the same ASIX AX88772 chipset as the Plugable (sic) one above. I have it connected to an iMac via Ethernet, and have set the iMac to have an IP address on that port of (subnet mask, but I’m not able to SSH.

It would be great to hook it up directly to the other machine, as my router is in a different room. Or could I use a different router in between them??

Edit: Is there a way to tell whether the USB dongle has been detected successfully?

yeah, pretty much all modern computers will detect direct connection to allow for this.

however, you have to setup your computer to then form the network connection.
I usually do this by bypassing dhcp, and assigning static ip addresses (on both sides)

did you change the settings as i described above to match you interface?
it’s unlikely it’ll work unless you make the change.

I cannot say Ive tried it explicity here , as I always want to go via my network

yes, you could can use multiple routers , and then form connections between them
you just have to make sure that things like dhcp are turned off… so your second router is acting more like a switch. a switch is better to use, unless you are trying to do something like linking routers via wifi, which is what Im doing.

how can you tell if its working?
as I said above you can see this on the SSP side, by restarting the network and using ‘ip a’
also look at the console logs (via dmesg) and use lsusb to check usb devices.

one thing I have noticed…
if the network is not in use, sometimes the SSP seems to shutdown the connection, and I have to reboot the SSP to get it working. also it prefers to connect to the network whilst the SSP is booting, rather than doing it a latter time (ie. hot plug)
I think this is likely something specifically to do with my USB ethernet dongle - so it may or may not be the case for you. ( I cannot remember what chipset my dongle uses)

Okay, attempting the instructions above… right now I’m trying to mount the SD card my Mac laptop, which doesn’t have the Debian system on it, as that has a card reader.

The rootfs filesystem doesn’t mount automatically, only BOOT does that. The others report that they are “Microsoft Basic Data” partitions - what does that refer to? FAT32? exFAT? These should supposedly mount also, so if anyone knows how to mount them on Mac…

I have also tried treating them as Linux ext4 filesystems (using FUSE) but it said they were not.

Sorry for continuing to ask basic (not SSP-specific) questions, but again Google is not being kind, and hopefully information shared here will help those that come after too!

I am getting a USB card reader, so will be able to try on the Debian system as well if that’s the best way.

You have to mount it from within a Linux VM
As you need to mount the rootfs which is ext2 format.

( there are some apps that allow this but frankly it’s better to do within a vm)

( might be ext3? can’t remember would need to check )

I got it going :sunglasses: I feel like a God! Maybe I’ll use the SSP as my regular computer :slight_smile:

Seriously though, it brings it home what @bert means about how you could run anything on there. It feels cool to be able to plug a keyboard in*… can SYNTHOR access the USB keyboard? Would make naming presets a lot easier, for one.

Need to figure out how to get the networking into the Debian VM, but that’s not an SSP-specific thing.

*It’s also interesting how you can type with the encoders!

1 Like

Yeah , did you see my little demo of running Orca from 100 rabbits on the SSP , that was pretty cool.
( but off-topic , should probably discuss possibilities in another post :wink: )