Input to multiple Granular modules

Bug description (state clearly and simply):
I am trying to use 1 INPut module to send 4 pitch signals to 4 different Granular modules. The problem is that when you connect an Input module to 4 GRA modules and send 1-4 cv inputs to pitch input on each sampler, the first Granular get’s all 4 signals into the pitch input and others get none.

Steps to reproduce (use numbered list):
As above.

Software version (blank if unknown):
16092018

Type (major or minor):
Not sure wether it is meant to work like that or not, but seems like a bug to me.

you should describe in more detail how you’ve patched everything together before I can say whether this is a bug or not :slight_smile:

1 Like
  1. Create 4 instances of Granular modules and set their pitch cv ins to RECEIVE.
  2. Create an INPut module and on the P page activate inputs 1,2,3,4.
  3. Connect input module to 4 Granular modules.
  4. While you currently have INP highlighted in the patcher grid, in it’s destination menu select 1:GRA: Pitch, 2:GRA:Pitch and so on until the 4th granular pitch input.
  5. In the patcher grid hover over the first connected GRAnular module’s pitch input, you should see that the number of connections it has is 4 and not 1. Granular 2,3,4 pitch inputs have 0 connections.

will try to reproduce and confirm what is going on

So I just tried what you described and it worked the way it should. That is all 4 GRA modules are receiving all 4 input signals from the input module. IE: the 4 input signals are getting summed and fed to each of the GRA modules.

To do what you want you would need to use 4 input modules each only connected to one GRA module.

This is because there is an automated connection system in place, that allows you to connect many modules and SUM signals. If you don’t want that you use an individual input or midi module.

It is possible that there is a bug here, because if the other GRA modules are not showing 4 incoming signals as well on the pitch input that would be wrong. I, however, did not have this problem. In fact I use this feature a lot when making multi layer voice patches.

In the above picture I have 1 input with inputs 1 through 4 enabled on the first analog input row. I have the input module connected to the 4 granular modules. From the output of the input module I have 1, 2, 3, and 4 of GRA pitch enabled. On each of the 4 GRA modules I have GRA pitch enabled on the module’s input section. This then shows 4 connections within each GRA module.

Could you let me know if I didn’t do something the way you did? Or if you have anything else I might be missing?

2 Likes

I built this patch using the latest software version. The 4 granular modules are each receiving 4 signals into their pitch input, from the input module. Those signals are summed because they target the same pitch input. The solution is to use 4 input modules like @2disbetter said above. So this is not actually a bug.

Videos below

What I was trying to do is not to sum all 4 signals from the input module, but route each of them separately to each granular module. I guess I need to understand that to do this I will need 4 input modules. The problem for me occured when the first granular module would get all 4 signals, but other 3 would get 0 (This is when I tried just one input module to send signal separately).

1 Like

Have you tried using 1 step sequencer to trigger 2 different envelopes with G1 and G2 respectively? I run into the same problem here, G1 was meant to control kick envelope and G2 for hihats. But what happened is i first made a kick pattern with G1 and then made a hihat pattern with G2, but since one instance of step sequnecer was connected to 2 instances of envelopes, the G1 and G2 patterns just got summed together and sent to both envelopes. To me it seems pretty annoying that the system doesnt recognise if there are multiple modules connected to it, it treats them as one. @bert

Basic things like these end up being more complicated than they should, to do what i wanted I would have to create another sequencer, sync it, make a separate hihat pattern and send to an envelope. It would have been much easier if separate outputs on the sequencer were all utilised in one unit.

1 Like

i suspected such behavior present, and you hand an excellent test to evaluate
maybe it got to do with the way we think about the in/out system

this is just how the patching system works. Like I explained before it patches semi automatically and in some situations it will work to your advantage and save you time, and in some situations you have to use multiple modules because it does not do what you want. You can use multiple step sequencers in this case.