000.8vwto question

The MIDI module on page 4 has additional send options that aren’t on pages 1, 2, 3, 5, 6, or 7.

Those being:

  • Pitch:MIDI: In
  • VelOn:MIDI: In
  • Gate:MIDI: In
  • VelOff:MIDI: In
  • ATouch:MIDI: In
  • CC7:MIDI: In
  • CC74:MIDI: In
  • CC1:MIDI: In

It seems that MIDI module is connected to an additional MIDI module somehow. Or to itself.

Is this a problem?

It’s probably harmless; none of those connections are highlighted, so (presumably) there is no info being transmitted to nor received by them.

But I am getting stuck notes right now (with three different MPE controllers), so I poked around looking for irregularities. This is what jumped out at me.

1 Like

yes, it’s possible you patched it to itself accidentally

no

it shouldn’t matter but you can just un-patch the module to itself

have you checked in the global menu if the MPE toggle is on? use LEFT/RIGHT to step through the parameter pages on the global menu until you find the MPE toggle.

Possible.

I made a duplicate of the patch before editing, discovered this in the duplicate, and then confirmed it was also in the original. I’ve tried not to write any changes to that.

…though, my duplicate did replace whatever was in patch #4, so I obviously haven’t figured everything out yet!

I see a “factory” directory on the SD card. Am I right in thinking I can copy from there to reset the file?

Fair enough. Let me figure out how to do that…

MPE is on.

(Beyond the red highlight, I’ve been playing with the per-voice aftertouch, and can confirm this is working.)

OK, i might have overlooked this, thanks for reporting

I recommend you get the preset you want from the latest preset collection I posted with the latest update.

when you are on the module, hold shift left or shift right depending on where the module is in the grid and then just press the button corresponding to the module (in the 8-button group to the left of your cursor keys)

OK. I have no problem with my roli seaboard block, no hanging notes. Is there a possibility you have to configure your MPE controller?

Ooh. Yes. I got the SYNTHOR file, but missed the updated preset collection. This might explain a few things.

Just spent some time testing with a non-MPE keyboard. No stuck notes, but also pitch bend is working as expected.

(I had some problems with pitch bend on my MPE controllers, and figured this module wasn’t meant to use it.)

Maybe?

I tested with Linnstrument (and tried a bunch of settings there, since the editor is built in), but also with a Seaboard Rise 49, and the newly arrived K-Board Pro 4. The K-Board is at default settings, because KMI shipped it without uploading their configuration utility. Seaboard, I probably need to configure.

But, yeah. They all behave the same.

So… I think the old presets probably aren’t entirely compatible with the new firmware. Replacing them seems like the right move.

Should I replace both sets on the SD card, or leave the Factory ones as-is?

note number and pitch bend data are used together to create the pitch signal that comes out of the MIDI module.

paging @jason @2disbetter … do you guys have problems using MPE controllers with the latest build?

it shouldn’t matter but just try with the latest preset collection to see if it changes your situation.

you should probably put the preset collection on your card both in the presets and factory folders. When you press the factory reset button the software will copy all presets from the factory folder into the presets folder, just FYI. The reset button is one of the buttons in the global menu. Be careful that you don’t overwrite presets you’ve created and want to keep!

1 Like

I checked this again and I can confirm you are right. It doesn’t have any effect though on the patch.

No so far I have not. I’m using a roli seaboard block with a bluetooth dongle. Everything maps the way it should. I’ll give it another whirl tonight and just verify that.

Edit: I gave it a whirl, and can confirm that pitch bend does not work through the midi module. I guess I hadn’t tried to do any pitch bending through midi recently. :roll_eyes:

bluetooth dongle connected to the SSP’s USB host port? is that something you got with your seaboard?

Nope. I bought it seperate. It is called a widi bud by CME. You just plug it into the SSP and power on the roli. It automatically pairs and everything.

Pitch bend is not working correctly for me, no.

If I slide from one pad to another on the x-axis, I get a new note on event immediately every time. I never get pitch bend.

works elsewhere

This is a dumb question Jason, but do you have MPE enabled in the global menu?

Yes, MPE is enabled in the global menu.

ok, i think there is a bug in the mpe code and i’ll get it fixed asap.

1 Like

no hanging notes like mentioned above?

I haven’t really noticed hanging notes, but what I meant by “works elsewhere” is that I am not having any issues with my Linnstrument and other gear or software, aside from the SSP.

That is an important clarification.

(I misread it as “all other patches are applying pitch bend correctly on SSP”, which would have directed troubleshooting towards how the midi module is implemented in this patch, and away from the midi module itself.)

So your pitch bend, confirmed working outside of SSP, has the same problem here that Bert and I noticed.

Yes, that’s correct.

MPE note hanging problem should be fixed in the last update.

should be fixed in the last update.

2 Likes